www.nhft.net > intEllij iDEA mAvEn 开发spArk环境搭建出现这个错误

intEllij iDEA mAvEn 开发spArk环境搭建出现这个错误

Plugin requires Maven version 3.0:插件需要Maven 3.0版本,你的是2.0 不支持

试一下File->Invalidate Caches/Restart 清除缓存重启 还不行就maven -> Reinport

File -- Invalidate Caches 然后会提示你重启intellij ,你重启后,就好了。应该是缓存的问题。落雨

这是一直在更新,文件下载大小258.99M,这么大更新需要时间,从你截图来看没问题,后面的x号,是你可以关闭停止更新,不是error。耐心等候就行了。如果找不到依赖,会终止下载,然后报错。不会一直停留在这么更新的界面中

如果是 idea 的话,右击 pom.xml 文件,选择最下面的 “ Add as maven build file”,然后编译器会重新构建,就好了

两者配置的CLASSPATH(Maven的依赖),相同吗

建议你使用intellij idea,在spark目录下执行"sbt/sbt gen-idea",会自动生成.idea项目,导入即可。

应该说这个和是不是Spark项目没什么关系。 建议你使用intellij idea,在spark目录下执行"sbt/sbt gen-idea",会自动生成.idea项目,导入即可。 idea我不熟,还需要做一些其他的插件配置(python, sbt等)和环境设置。 你也可以使用Eclipse看

第一步,先把explored加进去,然后启动tomcat,他会提示找不到。第二步,再点击就会成功发布部署的。

,但是这些依赖都已经通过pom引进了,idea的Library中也能看到,具体见下面图片配置maven 环境变量:系统变量:MAVEN_HOME = D:Servermaven用户变量:path =IntelliJ idea的maven工程老是提示:Cannot Resolv

网站地图

All rights reserved Powered by www.nhft.net

copyright ©right 2010-2021。
www.nhft.net内容来自网络,如有侵犯请联系客服。zhit325@qq.com